[risolto] you are using an older version of dropbox

Screenshot from 2016-06-13 23:17:35un infame errore che che drobox continuava a darmi su una installazione di ubuntu 12.04 LTS 32 bit sembrava senza via d’uscita, continuava a dirmi:

you are using an older version of dropbox

quindi tramite software center ho disinstallato dropbox e poi da shell:

rm -r ~/.dropbox-dist/

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86" | tar xzf -

~/.dropbox-dist/dropboxd

ci ha messo un pochino a risincornizzare il tutto ma poi e’ andato ok.

 

bash: determinare il path di una periferica usb

ecco un piccolo script bash per determinare il path dev di una periferica usb (ad es: /dev/ttyUSB0)

#!/bin/bash

for sysdevpath in $(find /sys/bus/usb/devices/usb*/ -name dev); do
    (
        syspath="${sysdevpath%/dev}"
        devname="$(udevadm info -q name -p $syspath)"
        [[ "$devname" == "bus/"* ]] && continue
        eval "$(udevadm info -q property --export -p $syspath)"
        [[ -z "$ID_SERIAL" ]] && continue
        echo "/dev/$devname - $ID_SERIAL"
    )
done

ecco un esempio di output

/dev/video0 - SuYin_HD_Video_WebCam_CN1014-S36D-OV05R-VA-R03.01.01
/dev/input/event7 - SuYin_HD_Video_WebCam_CN1014-S36D-OV05R-VA-R03.01.01
/dev/input/mouse0 - Logitech_USB_Optical_Mouse
/dev/input/event5 - Logitech_USB_Optical_Mouse

fonte: http://unix.stackexchange.com/questions/144029/command-to-determine-ports-of-a-device-like-dev-ttyusb0

howto fix: ubuntu update errore – The following signatures were invalid

se quando effettuate un aggiornamento sul vostro linux/ubuntu da terminale con il comando:

sudo apt-get update

ottenete un errore del genere:

GPG error: http://archive.ubuntu.com precise Release: The following signatures were 
invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key 
<ftpmaster@ubuntu.com>

potete ripristinare la situazione eseguendo i seguenti comandi da terminale:

cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get update

fonte: http://ubuntuforums.org/showthread.php?t=1983220

Come rilevare e risolvere ShellShock: il bug della bash shell

come rilevare shellshock

Per verificare se siete vulnerabili, aprite una shell (CTRL+ALT+T su Ubuntu) e digitate i seguenti comandi:

$ env x='() { :;}; echo vulnerable' bash -c "echo this is a test"

Se il risultato che ritorna è:

vulnerable
this is a test

allora il vostro pc è affetto da lbug.

se invece torna:

bash: warning: x: ignoring function definition attempt
bash: error importing function definition for `x'
this is a test

allora il vostro sistema è già patchato a dovere.

Come patchare shellshock

in attesa della patch ufficiale per utenti apple/osx andare a dare un occhiata su¬†readwrite.com l’articolo¬ How To Detect And Patch This Big, Bad Unix Bash Shellshock Bug

per utenti linux di tutte le distro:¬†fate l’upgrade standard del sistema la patch √® gi√† passata
http://seclists.org/oss-sec/2014/q3/650